Lighttpd checking for GTHREAD… configure: error: Package requirements (gthread-2.0 >= 2.4.0) were not met error and solution

Get real time updates directly on you device, subscribe now.

Q. I’m trying to install lighttpd 1.5.0 while compiling source code I’m getting an error which read as follows:

checking for GTHREAD… configure: error: Package requirements (gthread-2.0 >= 2.4.0) were not met:

No package ‘gthread-2.0’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTHREAD_CFLAGS
and GTHREAD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

How do I fix this issue; I’m using Fedora Core 6.x.

A. You need to install a package called glib2-devel. Lighttpd 1.5.x+ requires glib2-2.4.0 or higher.

Type the following command if you are using Redhat (RHEL) or Fedora Core or Cent OS:
# yum install glib2-devel

If you are using Debian/Ubuntu try following command:
# apt-get install libglib2.0-dev
OR
$ sudo apt-get install libglib2.0-dev

Now compile and install lighttpd:
# ./configure;make;make install
=>

Posted by: SXI ADMIN

The author is the creator of SXI LLC and a seasoned sysadmin, DevOps engineer, and a trainer for the Linux operating system/Unix shell scripting. Get the latest tutorials on SysAdmin, Linux/Unix and open source topics via RSS/XML feed or weekly email newsletter.

Get real time updates directly on you device, subscribe now.